プロジェクトを開くとき、または新規作成するときに、「Rserveが起動しないため、プロジェクトを開くことができませんでした」といったエラーのダイアログが表示される。

問題

プロジェクトを開くとき、または新規作成するときに、以下のようなエラーのダイアログが表示されることがあります。

原因

こちらのエラーは、ExploratoryのUIとRの間のをつなぐ役割をしているRserveというプログラムが起動しないときに表示されます。

Rserveが起動しない理由には様々な可能性がありますが、よくある原因は、Rパッケージが正しくインストールされていない、または、AvastやAVGといったウィルス対策ソフトウェアが、Rserveの起動を止めていたり、Rserveの実行ファイルを削除してしまっていたりといったことがあります。

その他の可能性としては、起動したRserveプロセスを見つけるためにExploratoryが利用するnetstatなどのコマンドが、Path環境変数の設定ミスで利用できなくなっているといったこともあります。

解決方法

はじめに、Rserveや、他のRパッケージの一部がすでに消去されてしまっている可能性があるため、こちらのノートを参考にRパッケージのリセットをお試しください。

もしそれでもプロジェクトを開いたときにエラーが出る場合は、ウィルス対策ソフトウェアのアクティビティ・ログを確認して、Rserveがブロックされていたり消去されている場合は、今後ブロック、消去されないように例外を設定します。

以上の処置をとってもまだ同じエラーが出続ける場合は、WindowsのPath環境変数に、C:\Windows\System32%SystemRoot%\System32%SystemRoot%\system32のいずれかが含まれていることを確認してください。もし、どれも含まれていない場合は、C:\Windows\System32を追加してください。その後、Exploratoryを再起動して、プロジェクトが無事開けるかどうかを確認してください。

レポジトリがネットワークドライブにある場合

また、レポジトリをネットワークドライブに設定されている時にもRserveが起動しない問題を報告いただいています。

もしレポジトリがネットワークドライブである必要がない場合は、こちらのノートを参考にレポジトリの場所を変更ください。

また、プロジェクトのみをネットワークドライブに設定したい場合は、こちらのノートにプロジェクトだけをネットワークドライブに置く方法を紹介しています。

「いいね!」 1