Exploratory サーバーをバージョンアップした際、「docker-compose up -d」を実行した際、以下のようなエラーが表示されることがあります。
Error response from daemon: Get "https://registry-1.docker.io/v2/":net/http: request canceled while waiting for connection(Client.Timeout exceeded while awaiting headers)
Error response from daemon: pull access denied for r-exploratory,repository does not exist or may require 'docker login':denied: requested access to the resource is denied
これらのエラーは多くの場合、ディスク容量が足りないことで、r-exploratory、exploratory、schedulerなどのイメージがDockerのイメージがロードできてなかったことで発生していることが想定されます。
解決方法
イメージのロードには十分な空き容量が必要です。特にr-exploratoryイメージはサイズが大きいため、空き容量が不足していると正常にロードできないことがあります。
df -h
空き容量が不足している場合は、不要なファイルや使用していないDockerイメージなどを整理してください。
空き容量を確保しましたら、バージョンアップ用ファイルに含まれるr-exploratoryのイメージファイルを指定し、案内されているdocker loadコマンドを再実行し、Dockerのイメージを再度ロードしてください。
docker load -i exploratory-server-images-<<version>>.tar.gz
docker loadは複数回実行しても問題ありません。実行後、エラーが表示されず、正常に完了したことを確認してください。
次に、以下のコマンドでExploratory Serverを起動し、エラーが解消されるかを確認してください。
docker-compose up -d