Exploratory コミュニティ

Exploratory 6.8 Windows版にアップグレード後、"w[1].version_command.unshift is not a function"というエラーが出る

#1

昨日リリースしました、Exploratory 6.8 Windows版にアップグレード後、"w[1].version_command.unshift is not a function"というエラーが出てアップグレードを完了できないという問題があります。

これは、カスタムのRの場所が指定されている場合に起こります。

回避策として、レポジトリディレクトリ(デフォルトの場所はC:/Users/<Windowsユーザー名>/.exploratory)の下にあるuserconf.jsonファイルをメモ帳などのエディタで開き、以下の例のように"r_path"で始まる行を削除してください。

変更前の例:

    ...
    "proxy": {},
    "r_path": "C:/Users/hideaki/Documents/R/R-4.1.0"
}

変更後の例:

    ...
    "proxy": {}
}

上の例のように、"r_path"の行が、}の前の最後の行になっているときは、その前の行(この場合、"proxy": {},)の最後のコンマ,を消す必要があることにもご注意ください。

この変更の後Exploratoryを再起動して、アップグレードが完了するか試してみてください。
それでも問題があるとき、またはよくわからないときはサポート(support@exploratory.io)までお問い合わせください。